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How to create and edit a CSS rule
You can create and edit a CSS rule in two locations: the Properties panel and the CSS Styles panel. When you apply 
CSS styles to text by using the Properties panel or menu commands, CSS rules are embedded in the head of the 
current document. You can also use the CSS Styles panel to create and edit CSS rules and properties. 

In this guide, you review CSS rules, create and apply a class-style CSS rule by using the Properties panel, and modify 
an HTML tag-style rule by using the CSS Styles panel.

About CSS rules
A CSS formatting rule consists of two parts: the selector and the declaration (or in most cases, a block of 
declarations). The selector is a term (such as p, h1, a class name, or an id) that identifies the formatted element. The 
declaration block defines the style properties. In the following example, h1 (a heading tag) is the selector, and 
everything that falls between the braces ({and }) is the declaration block (defining the properties of the h1 heading):

h1 { 

font-family: Georgia, "Times New Roman", Times, serif;

font-size: 18px;

text-transform: uppercase;

color: #090; 

}

An individual declaration consists of two parts: the property (such as font family) and value (such as Georgia). In the 
previous CSS rule, a particular style has been created for h1 tags; the text for all h1 tags linked to this style will be 18 
pixels in size, Georgia font, uppercase, and bright green (hex value #090). 

The style (which comes from a rule, or a collection of rules) resides in a place separate from the actual text it’s 
formatting—usually in an external style sheet or in the head section of an HTML document. Thus, one rule for h1 
tags can apply to many tags at once (and in the case of external style sheets, the rule can apply to many tags at once on 
many different pages) (Figure 1). In this way, CSS provides extremely easy update capability. When you update a 
CSS rule in one place, the formatting of all the elements that use the defined style is automatically updated to the new 
style.

Figure 1 Updating a CSS rule in one place updates all elements
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There are three main types of CSS:

Class style: Similar to the styles you use in word processing and page layout programs. For example, you may 
want to format all body text in 10-point, Arial, dark green type. You can create a class style with these attributes 
and then apply this style to all body text in your website. Class names must begin with a period and can contain 
any combination of letters and numbers (for example, .myhead1). 

HTML tag style: Applies global formatting to individual HTML tags rather than to individual selections. 
Suppose you want to modify the Heading 1 paragraph style to appear always in purple text. Instead of creating a 
class style and applying it to every heading in the document, you can create an HTML tag style with these 
attributes and apply it to the Heading 1 <h1> tag. In effect, you are redefining the HTML tag.

ID style: A unique identifier (ID) for a style applied to headers, banners, menus, and other elements present in 
only one location in the document. Used once within a document or page. IDs must begin with a pound (#) sign 
and can contain any combination of letters and numbers (for example, #myID1). 

CSS rules can reside in the following locations:

Internal (or embedded) CSS style sheets are collections of CSS rules included in a style tag in the head section of 
an HTML document.

External CSS style sheets are collections of CSS rules stored in a separate, external CSS (.css) file (not an HTML 
file). You link this file to one or more pages in a website with a link or an @import rule in the head section of a 
document. 

Creating a new CSS rule from the Properties panel
In the CSS Properties panel, you can access Targeted Rules and create new ones (Figure 2). A Targeted Rule is a rule 
you are editing in the CSS Properties panel. When you have an existing style applied to text, the rule affecting the 
text’s format appears when you click inside the text on the page. You can also use the Targeted Rule pop-up menu to 
create new CSS rules and new in-line styles or apply existing classes to selected text. 

Figure 2 Properties panel, CSS mode

How you edit your CSS depends on selection level. To access rules that apply to a current selection only, you can use 
the Targeted Rule pop-up menu in the CSS Properties panel. To access all CSS rules for a page, you can use the CSS 
Styles panel. The CSS Styles panel will be reviewed in the next guide.

In this section, you use the Properties panel to create a simple CSS class-style rule to format a block of text.
How to create and edit a CSS rule © 2012 Adobe Systems Incorporated



Adobe Dreamweaver CS6 Project 1 guide
To create a new CSS rule in the Properties panel:

1. Start Dreamweaver.

2. Select File > New to create a new document.

The New Document dialog box appears (Figure 3).

3. In the Blank Page category of the New Document dialog 
box, select HTML Page Type to create a plain HTML 
page.

4. In the Layout column, select None. 

5. Click the Create button.

The new HTML page opens.

6. In the Document toolbar, click the Show Code And 
Design Views (Split) button (Figure 4).

Being able to view the code that Dreamweaver generates 
for creating styles will be useful to help you understand 
and write your own CSS syntax later on.

7. Type some text or paste text copied in another application 
in the Design view Document window. 

8. Press Enter (Windows) or Return (Mac OS) to create a 
new paragraph and add additional text.

9. Open the Properties panel (Window > Properties), if it 
isn’t already open, and click the CSS button to display 
the CSS Properties panel (Figure 2).

10. Use the Font menu to change the Font to Georgia, Times 
New Roman, Times, Serif (Figure 5).

The New CSS Rule dialog box appears (Figure 6).

Note: It is a good practice to assign a font combination 
instead of a single font. This ensures that most page 
visitors will view page text the same way. A browser uses 
the first font in the combination that is installed in the 
visitor’s system. If none of the fonts in the combination is 
installed, the browser displays the text as specified by the 
visitor’s browser preferences. 

Figure 3 New Document dialog box

Figure 4 Document window view options

Figure 5 Properties panel Font menu

Figure 6 New CSS Rule dialog box

Show Code And Design Views button
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11. In the Selector Type menu, select Class (Can Apply To 
Any HTML Element) (Figure 7).

12. Click in the Selector Name text box and type .myStyle 
(Figure 8).

Note: CSS rules must begin with a period and cannot 
contain spaces or special characters.

13. In the Rule Definition menu, select (This Document 
Only) (Figure 9).

This tells Dreamweaver to create and store the CSS (style 
sheet) in the current document only. The new style will 
not be available for use in other documents.

To create an external CSS document for your entire 
website, you would choose (New Style Sheet File). This 
is discussed in a later guide.

14. Click OK to close the New CSS Rule dialog box.

The new font is applied to the paragraph that contains the 
insertion point. The name of the style appears in the 
Targeted Rule box in the Properties panel (Figure 10).

Note: Because you didn’t select a specific word or 
character, you can continue to define this rule by 
applying additional formatting.

15. In the Properties panel, change the size to 18.

The font size in the paragraph that contains the insertion 
point changes accordingly.

Figure 7 New CSS Rule dialog box, Selector Type 
options

Figure 8 New CSS Rule dialog box, Selector 
Name options

Figure 9  New CSS Rule dialog box, Rule 
Definition options

Figure 10 Targeted Rule in the Properties panel
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16. Click the Color box in the Properties panel and select a 
new color for the text.

The Properties panel shows the targeted rule (.myStyle) 
and its formatting. The targeted rule is applied to the 
paragraph that contains the insertion point (Figure 11).

You can use this CSS rule to format additional text in 
your document.

Observe in Code view that Dreamweaver stores styles 
created with CSS directly in the head section of the 
document (Figure 12).

Figure 11 Formatted paragraph text

Figure 12 Detail of new CSS rule, Code view
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Applying CSS styles
After you create a CSS rule, you can use it to give your entire document or website a consistent appearance. You can 
apply a CSS rule to text by using the Properties panel.

To apply a CSS style:

1. Click anywhere in the paragraph that doesn’t have the 
new CSS style.

2. In the Properties panel, select myStyle (the new CSS rule 
you just created) from the Targeted Rule menu 
(Figure 13).

The new style is applied to the other paragraph 
(Figure 14).

Note: If you edit the CSS style, both paragraphs will be 
updated automatically and consistently. You will learn 
more about creating and modifying CSS in a later guide.

Figure 13 Targeted Rule menu

Figure 14 CSS style applied to both paragraphs

Using the CSS Styles panel
In the CSS Styles panel you can track the CSS rules and properties affecting a currently selected page element 
(Current mode) or all of the rules and properties available to the document (All mode). A button at the top of the 
panel enables you to switch between the two modes. You can also use the CSS Styles panel to modify CSS properties 
in both All and Current modes. 
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The CSS Styles panel in Current mode

In Current mode, the CSS Styles panel displays three panes: a Summary For Selection pane that displays the CSS 
properties for the current selection in the document, a Rules pane that displays the location of selected properties (or 
a cascade of rules for the selected tag, depending on your selection), and a Properties pane where you can edit CSS 
properties for the rule applied to the selection (Figure 15).

Figure 15 CSS Styles panel, Current mode

The CSS Styles panel in All mode

In All mode, the CSS Styles panel displays two panes: an All Rules pane, and a Properties pane. The All Rules pane 
displays a list of rules defined in the current document as well as all rules defined in style sheets attached to the 
current document. You can use the Properties pane to edit CSS properties for any rule selected in the All Rules pane 
(Figure 16).

Figure 16 CSS Styles panel, All mode

New CSS Rule Edit RuleAttach Style Sheet
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To add a CSS rule by using the CSS Styles panel:

1. Start Dreamweaver.

2. Create a new HTML document.

3. Save and name the Dreamweaver document.

4. Type some text in the document. Make sure no 
formatting is applied to the text (Figure 17).

5. Make sure the CSS Styles panel is open.

If it is not, select Window > CSS Styles.

6. To create a new style, click the New CSS Rule button (+) 
at the bottom of the panel (Figure 15).

The New CSS Rule dialog box appears (Figure 18).

7. In the Selector Type pop-up menu, select Class. 

This option creates a new Class rule.

8. In the Selector Name text box, type a name for the style 
such as .warning.

Note: Class rule names must begin with a period and 
cannot contain spaces or special characters. If you forget 
to type the period, Dreamweaver adds this automatically.

9. In the Rule Definition pop-up menu, select (This 
Document Only) or (New Style Sheet File). 

The option (This Document Only) defines the style as 
part of the document’s internal style sheet. The option 
(New Style Sheet File) defines the style as part of an 
external style sheet.

Note: If you choose to create an external style sheet by 
selecting (New Style Sheet File), you are prompted to 
select a location for the new style sheet (.css) document.

10. Click OK.

The CSS Rule Definition dialog box appears (Figure 19).

11. Select options for Type, such as the following: 

• Select Arial, Helvetica, Sans-serif in the Font-
Family pop-up menu

• Select 12 from the Font-Size pop-up menu, and 
select px (pixels) for the measurement unit.

• Type #CC0033 in the Color text box, or select a 
color in the color picker.

Figure 17 Text with no formatting applied

Figure 18 New CSS Rule dialog box

Figure 19 CSS Rule Definition dialog box, Type 
options 
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12. To change the formatting of text blocks, select Block in 
the Category pane.

The Block category of the CSS Rule Definition dialog 
box opens (Figure 20).

13. In the Letter-Spacing text box, you can make changes 
such as typing 3 and selecting pixels for the measurement 
unit.

This setting adds space between letters. 

14. In the Text-Indent box, you can make changes such as 
typing 5 and selecting pixels for the measurement unit.

15. Click OK.

The CSS Rule Definition dialog box closes.

16. Select the document text.

17. Make sure the Properties panel is open and the HTML 
option is selected.

The Properties panel is docked at the bottom of the 
screen. If it is not open, select Window > Properties.

18. Select warning, or the name of your style, from the Class 
pop-up menu (Figure 21).

19. In the document, deselect the text by positioning the 
mouse pointer next to it and clicking once.

Observe that the format of the text has changed 
(Figure 22).

20. Make sure the CSS Styles panel is open.

If it is not, select Window > CSS Styles.

21. Make sure All is selected in the CSS Styles panel. If no 
styles are listed under <style> in the All Rules pane, click 
the plus (+) symbol (Windows) or the disclosure triangle 
(Mac OS).

Observe that the newly created CSS rule now appears 
under <style> in the All Rules pane, indicating the new 
rule is part of a CSS style sheet. Also observe that if you 
select the style name in the All Rules pane, properties for 
the style appear in the Properties pane.

Figure 20 CSS Rule Definition dialog box, Block 
options 

Figure 21 Text Properties panel

Figure 22 Formatting applied to text
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Edit styles

After you create styles, you can still make changes to them by using the Edit Rule button.

To edit styles:

1. To view a style sheet’s rules, click the plus symbol 
(Windows) or disclosure triangle (Mac OS) beside 
<style> in the All Rules pane of the CSS Styles panel.

Dreamweaver displays the style sheet’s rules 
(Figure 23). 

2. Select the rule or style you want to edit.

3. At the bottom of the CSS Styles panel, click the Edit Rule 
button.

The CSS Rule Definition dialog box for the selected style 
appears (Figure 24).

4. Make formatting changes in the CSS Rule Definition 
dialog box. Then click OK.

The changes take effect immediately. 

If you are editing an external style sheet, the same 
changes are applied to any other documents attached to 
this style sheet.

Figure 23 CSS Styles panel

Figure 24 CSS Rule Definition dialog box

Edit Rule 
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